NF-e 4.0 vai parar de funcionar nas versões XP, Vista e 2003 do Windows

De acordo com a Nota Técnica 2016.002 v 1.60, da Secretaria da Fazenda (SEFAZ), a versão 3.10 da NF-e será desativada no início do mês de agosto deste ano (02/08/2018). A nova versão NF-e 4.0 entrará em vigor, em definitivo, a partir desta data.
Para atender as necessidades de segurança, exigidas para envio dos arquivos XML para a SEFAZ, será utilizado um protocolo chamado TLS 1.2. As versões do Sistema Operacional Windows XP, Vista e 2003 não possuem suporte para esse protocolo, o que impossibilita as máquinas emissoras de realizarem a comunicação com os servidores da Secretaria, bloqueando o envio das informações.
O que é o protocolo TLS 1.2? O protocolo TLS (Transport Layer Security) oferece criptografia para as informações enviadas e recebidas através da internet, permitindo comunicação segura entre um computador e um servidor. Utilizados para transações bancárias, comércio eletrônico, pagamentos pela web e transmissão de documentos com sigilo e segurança.
Como proceder? Caso sua empresa possua algum desses sistemas operacionais citados, é necessário que seja feita a atualização para a versão Windows 10. Caso contrário, não poderá emitir NF-e.
Embora a versão Windows 7 também funcione, ela deve possuir o Service Pack 1 instalado. Porém, já foi anunciado que essa versão do sistema operacional também deverá ser descontinuada pela Microsoft em 2019.
Reforçamos que os clientes que possuem esses Sistemas Operacionais nas máquinas que emitem NF-e, sigam as orientações abaixo:
Windows XP: Trocar o sistema operacional. Não há suporte de TLS no XP.
Windows Vista: Trocar o sistema operacional. Não há suporte de TLS no Vista.
Windows 7: Instalar o Service Pack 1. Instalar todas as atualizações através das atualizações automáticas.
Windows 8: atualizar para o Windows 8.1 e instalar todas as atualizações através das atualizações automáticas.
Outras versões do Windows e Windows Server: Instalar todas as atualizações automáticas para que o suporte ao protocolo TLS 1.2 esteja disponível. Necessário aplicar uma correção imprescindível para o protocolo TLS 1.2 no Framework .Net, para que o protocolo TLS 1.2 esteja instalado/atualizado.
Cuidados com seus dados É recomendável que essa atualização seja feita o mais breve possível para que não
haja contratempos e sua empresa seja prejudicada, ficando sem emitir notas fiscais.
Alertamos que essa mudança não é uma característica das soluções da AG Sistemas. Trata-se de uma atualização visando segurança imposta pelo ENCAT ao ambiente NF-e. Todo emissor de NF-e, NFC-e, CT-e e MDF-e serão afetados por essa alteração.
Os clientes AG Sistemas terão todo apoio no que se refere à reinstalação do sistema. Nossos sistemas estão atualizados para os padrões e atualizações impostos pela SEFAZ, mas devem ficar atento ao seu banco de dados, para que as informações não sejam perdidas.
Para quaisquer dúvidas, entre em

Deixe uma resposta

O seu endereço de e-mail não será publicado. Campos obrigatórios são marcados com *